Ubuntu 18.04.1 repositores are not working

Today I fired up my LapTop, logged into Ubuntu and ran

 sudo apt-get update 

Then this happened.

Get:1 file:/var/cuda-repo-10-0-local-10.0.130-410.48  InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.130-410.48  InRelease
Get:2 file:/var/cuda-repo-10-0-local-10.0.130-410.48  Release [574 B]
Get:2 file:/var/cuda-repo-10-0-local-10.0.130-410.48  Release [574 B]
Get:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Hit:5 http://ppa.launchpad.net/thomas-schiex/blender/ubuntu bionic InRelease   
0% [3 InRelease gpgv 83.2 kB] [Connecting to ir.archive.ubuntu.com (185.142.156^0% [Connecting to ir.archive.ubuntu.com (185.142.156.14)]          13.Err:6 http://ir.archive.ubuntu.com/ubuntu bionic InRelease                                                                                           
  Could not connect to ir.archive.ubuntu.com:80 (185.142.156.14), connection timed out
Err:7 http://ir.archive.ubuntu.com/ubuntu bionic-updates InRelease
  Unable to connect to ir.archive.ubuntu.com:http:
Err:8 http://ir.archive.ubuntu.com/ubuntu bionic-backports InRelease
  Unable to connect to ir.archive.ubuntu.com:http:
Fetched 83.2 kB in 31s (2,712 B/s)
Reading package lists... Done
W: Failed to fetch http://ir.archive.ubuntu.com/ubuntu/dists/bionic/InRelease  Could not connect to ir.archive.ubuntu.com:80 (185.142.156.14), connection timed out
W: Failed to fetch http://ir.archive.ubuntu.com/ubuntu/dists/bionic-updates/InRelease  Unable to connect to ir.archive.ubuntu.com:http:
W: Failed to fetch http://ir.archive.ubuntu.com/ubuntu/dists/bionic-backports/InRelease  Unable to connect to ir.archive.ubuntu.com:http:
W: Some index files failed to download. They have been ignored, or old ones used instead.

Any ideas what could cause this?
Could it be that those links are not working anymore? If so where can I find new ones?

Thank you <3

Here is Solutions:

We have many solutions to this problem, But we recommend you to use the first solution because it is tested & true solution that will 100% work for you.

Solution 1

The core issue is that the Mirror in use by the ir.archive.ubuntu.com DNS Round Robin that you landed on is not working properly.

About 2 minutes ago relative to this post, the notification of this mirror timing out to the Ubuntu Mirrors team (part of Canonical’s Systems Administration teams) indicating that they have, for now, removed the IP from the round robin rotation due to the timeouts (for now).

Note: Use and implement solution 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply