"package is in a very bad inconsistent state – you should reinstall it before attempting configuration."

Recently, i was installing the new version from 13.04 to 13.10 ubuntu while also watching a video. Well, guess what happened, my desktop crashed for like 4 minutes and then upon gaining access to the desktop again everything seemed messed up like box symbols where characters should be.

I know it was a bad idea but i decided to reboot halting the installation process and now i am stuck with this error.

dpkg: error processing unity-lens-photos (--configure):
package is in a very bad inconsistent state - you should reinstall it before attempting configuration.

Errors were encountered while processing: untity-lens-photos
e: subprocess /usr/bin/dpkg returned an error code (1).

And it pretty much pops up everytime i try to upgrade, or install anything. This was after i finished updating the rest of my files. I have tried many things and read many threads. I am really lost right now, please help.

Also i have no access to a panel and i am currently trying everything in the terminal. Attempts to install a gnome panel have been halted by the error.

Here is Solutions:

We have many solutions to this problem, But we recommend you to use the first solution because it is tested & true solution that will 100% work for you.

Solution 1

package is in a very bad inconsistent state – you should reinstall it before attempting configuration.

The issue is easy to fix. Just reinstall the package:

sudo apt-get --reinstall install unity-lens-photos

Simply removing the package shouldn’t be done since it could leave behind files or directories that were not cleaned by the removal script. If you want to remove it, do it afterwards the reinstallation.

Solution 2

Try to remove untity-lens-photos package by running the below command,

sudo dpkg -r untity-lens-photos

And then reinstall it by running,

sudo apt-get install untity-lens-photos

Solution 3

I had the same problem with the library libgcc1:i386. After running sudo apt-get --reinstall install libgcc1, I got following message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
 libgcc1:i386 : Depends: libc6:i386 (>= 2.2.4)
 but it is not going to be installed

So at the end, simply running

sudo apt-get -f install

repaired the package installation.

Afterwards I removed it, because I did not needed it.

Note: Use and implement solution 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply