How do I install Gimp 2.7?

I just reinstalled my Ubuntu system with 11.10, but ran into a problem when I tried to install Gimp 2.7.

I always get unmet dependencies (it’s german, so I can’t tell you the exact english translation):

Needs gimp-data (<= 2.6.11-z) but 2.7.3-2011082002~oo should be installed

I already read the follow post, but the answers didn’t really help me.

When I type in

sudo apt-get install gimp=2.6

it just says that there is no version 2.6 found. I get the same with 2.7.

I really need Gimp. But installing Gimp 2.6 isn’t possible as well.

When I remove the repos for 2.7, I still get the same error.

Here is Solutions:

We have many solutions to this problem, But we recommend you to use the first solution because it is tested & true solution that will 100% work for you.

Solution 1

The following thing did it for some reason.

It seemed like the problem was a gimp-data 2.7 package, that was still installed after I removed the ppa ppa:matthaeus123/mrw-gimp-svn .

After I removed this package and then removed the ppa:matthaeus123/mrw-gimp-svn it installed gimp 2.6 immediately.

I tried to add the ppa again (to install 2.7, because I made a file with that and need to open it – which doesn’t work with 2.6), but always got an error about a missing libbabl.0.so.0 file (although it was installed).

I also tried this ppa which I stumbled upon:
https://launchpad.net/~alex-p/+archive/notesalexp-oneiric

I also checked the list of sources when I do an apt-get update, but it’s not even in there.

At least I have one gimp.

But if somebody knows a trick that is worth trying, I’d love to hear it.
(it has gimp 2.73 in it, but when I add it and also activate it nothing happens)

Solution 2

Try to install it again using this PPA: ppa:matthaeus123/mrw-gimp-svn

I installed GIMP this way without unmet dependencies problems.

Solution 3

If you want to use the ppa mentioned for gimp it only has i386 packages for 11.10, the amd64 failed to build quite some time ago.

If your on a 64 bit install then just use 11.10’s version which is simply named gimp

Solution 4

EDIT: Be warned that adding the repositories from my post here and updating your packages from there may BREAK your GTK+ settings (themes) and such.


Actually when you add the repository for matthaeus123 it indicates what needs to be done:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn

It mentions that there are packages in oneiric that need to be updated. So then add:

sudo add-apt-repository http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu
sudo add-apt-repository http://ppa.launchpad.net/ricotz/testing/ubuntu

That seems to fix the dependency problems.

If you are getting an error like this:

gimp: error while loading shared libraries: libbabl-0.0.so.0: cannot open shared

You can try fixing it by entering this into a terminal:

sudo apt-get remove libbabl-0.0-0
sudo apt-get clean
sudo apt-get install gimp

Solution 5

I’d appreciate not making any posts look like a solution when they are not (SimonEritsch’s answer).

As I understand it there are no amd64 packages available yet (thank you doug for the information) and currently this would be the only proper answer to the original question.

As for the tip to try to install this – installation failed.

Related post http://ubuntuforums.org/showthread.php?t=1834302


EDIT:
@imonEritsch

It did nothing. Probably you ended up with GIMP 2.6.x.

Here’s a solution to install GIMP 2.7.4. Tested on ubuntu 11.10 x64.

1. Open the Terminal and issue the following commands:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn
sudo apt-get update

2. Run Software Center, search for GIMP, press ‘More info’ (it should already state that you’re about to install 2.7.4) and install it without changing any options.

Now, the above is bit by bit what I did that gave me a working GIMP without any additional hassling but the following should work as well:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn
sudo apt-get update
sudo apt-get install gimp

Edit:
The last 3 commands method confirmed working.

Solution 6

You need to remove gimp, gimp-data and libgimp 2.7.3 manually.
Remove the mattheus ppa and restart ubuntu. then you should able to install gimp 2.6.11. Good luck.

Note: Use and implement solution 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply