Errors encountered when installing kubuntu on 15.04

I ran:

sudo add-apt-repository ppa:kubuntu-ppa/backports
sudo apt-get update
sudo apt-get install kubuntu-desktop

and after it gave me this error message:

dpkg: error processing archive /var/cache/apt/archives/kde-config-telepathy-accounts_15.04.1-0ubuntu1~ubuntu15.04~ppa1_i386.deb (--unpack):
 trying to overwrite '/usr/share/accounts/services/google-im.service', which is also in package account-plugin-google 0.12+15.04.20150415.1-0ubuntu2
Errors were encountered while processing:
 /var/cache/apt/archives/kde-config-telepathy-accounts_15.04.1-0ubuntu1~ubuntu15.04~ppa1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

and whenever I try to install a new program or run the suggested solution to this problem, which was mentioned after I tried to install another program, sudo apt-get -f install I get the same error message again.

EDIT: Requested outputs.

sudo apt-get --configure -a

gives this (too large to fit in the question).

sudo apt-get install -f

gives:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  kde-config-telepathy-accounts
The following NEW packages will be installed
  kde-config-telepathy-accounts
0 to upgrade, 1 to newly install, 0 to remove and 23 not to upgrade.
2 not fully installed or removed.
Need to get 0 B/131 kB of archives.
After this operation, 697 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 1088636 files and directories currently installed.)
Preparing to unpack .../kde-config-telepathy-accounts_15.04.1-0ubuntu1~ubuntu15.04~ppa1_i386.deb ...
Unpacking kde-config-telepathy-accounts (15.04.1-0ubuntu1~ubuntu15.04~ppa1) ...
dpkg: error processing archive /var/cache/apt/archives/kde-config-telepathy-accounts_15.04.1-0ubuntu1~ubuntu15.04~ppa1_i386.deb (--unpack):
 trying to overwrite '/usr/share/accounts/services/google-im.service', which is also in package account-plugin-google 0.12+15.04.20150415.1-0ubuntu2
Errors were encountered while processing:
 /var/cache/apt/archives/kde-config-telepathy-accounts_15.04.1-0ubuntu1~ubuntu15.04~ppa1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

while running:

cat /etc/apt/sources.list

gives:

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://au.archive.ubuntu.com/ubuntu/ vivid main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ vivid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://au.archive.ubuntu.com/ubuntu/ vivid-updates main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ vivid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://au.archive.ubuntu.com/ubuntu/ vivid universe
deb-src http://au.archive.ubuntu.com/ubuntu/ vivid universe
deb http://au.archive.ubuntu.com/ubuntu/ vivid-updates universe
deb-src http://au.archive.ubuntu.com/ubuntu/ vivid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://au.archive.ubuntu.com/ubuntu/ vivid multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ vivid multiverse
deb http://au.archive.ubuntu.com/ubuntu/ vivid-updates multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ vivid-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://au.archive.ubuntu.com/ubuntu/ vivid-backports main restricted universe multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ vivid-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu vivid-security main restricted
deb-src http://security.ubuntu.com/ubuntu vivid-security main restricted
deb http://security.ubuntu.com/ubuntu vivid-security universe
deb-src http://security.ubuntu.com/ubuntu vivid-security universe
deb http://security.ubuntu.com/ubuntu vivid-security multiverse
deb-src http://security.ubuntu.com/ubuntu vivid-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner
deb http://download.virtualbox.org/virtualbox/debian vivid contrib

Here is Solutions:

We have many solutions to this problem, But we recommend you to use the first solution because it is tested & true solution that will 100% work for you.

Solution 1

That is the problem:

dpkg: error processing archive /var/cache/apt/archives/kde-config-telepathy-accounts_15.04.1-0ubuntu1~ubuntu15.04~ppa1_i386.deb (--unpack):
 trying to overwrite '/usr/share/accounts/services/google-im.service', which is also in package account-plugin-google 0.12+15.04.20150415.1-0ubuntu2

Therefore two command in a terminal:

sudo apt-get purge account-plugin-google
sudo apt-get install -f

Solution 2

I saw the attached link.

I think you need to do:-

sudo apt-get remove --purge kde-telepathy-minimal
sudo apt-get remove --purge kde-telepathy

Also, try to remove orphaned packages using apt-get autoremove

EDIT: If that didn’t work, try installing Aptitude:

Install aptitude:

sudo apt-get aptitude

Run it:

sudo aptitude purge kde-telepathy
sudo aptitude purge kde-telepathy-minimal

Solution 3

This is a bug already reported in Ubuntu, Kubuntu PPA and also in KDE:

https://bugs.launchpad.net/ubuntu/+source/kaccounts-providers/+bug/1488909
https://bugs.launchpad.net/kubuntu-ppa/+bug/1451728
https://bugs.kde.org/show_bug.cgi?id=347219

Note: Use and implement solution 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply