Invalid SOS parameters for sequential JPEG

I’ am getting this error when use imagecreatefromjpeg function.

Warning: imagecreatefromjpeg(): gd-jpeg, libjpeg: recoverable error: Invalid SOS parameters for sequential JPEG in C:\wamp\www\test\index.php on line 7

I researched, with this commands pass errors fine, works good.

ini_set("gd.jpeg_ignore_warning", 1);
error_reporting(E_ALL & ~E_NOTICE);

But I am wondering what is wrong this?

here my image exif data

Array
(
    [FileName] => 1.jpg
    [FileDateTime] => 1455186386
    [FileSize] => 1364340
    [FileType] => 2
    [MimeType] => image/jpeg
    [SectionsFound] => ANY_TAG, IFD0, COMMENT, EXIF
    [COMPUTED] => Array
        (
            [html] => width="2592" height="1944"
            [Height] => 1944
            [Width] => 2592
            [IsColor] => 1
            [ByteOrderMotorola] => 0
            [ApertureFNumber] => f/1.9
            [UserComment] => 
            [UserCommentEncoding] => UNDEFINED
        )

    [ImageWidth] => 2592
    [ImageLength] => 1944
    [Make] => samsung
    [Model] => SM-G920F
    [Orientation] => 8
    [XResolution] => 72/1
    [YResolution] => 72/1
    [ResolutionUnit] => 2
    [Software] => G920FXXU3COJ1
    [DateTime] => 2016:02:10 18:48:36
    [YCbCrPositioning] => 1
    [Exif_IFD_Pointer] => 226
    [COMMENT] => Array
        (
            [0] => File written by Adobe Photoshop¨ 5.0
        )

    [ExposureTime] => 1/25
    [FNumber] => 19/10
    [ExposureProgram] => 2
    [ISOSpeedRatings] => 200
    [ExifVersion] => 0220
    [DateTimeOriginal] => 2016:02:10 18:48:36
    [DateTimeDigitized] => 2016:02:10 18:48:36
    [ShutterSpeedValue] => 464/100
    [ApertureValue] => 1851/1000
    [BrightnessValue] => 33/100
    [ExposureBiasValue] => 0/10
    [MaxApertureValue] => 1851/1000
    [MeteringMode] => 2
    [Flash] => 0
    [FocalLength] => 220/100
    [MakerNote] => 0100 [email protected]
    [UserComment] => 
    [FlashPixVersion] => 0100
    [ColorSpace] => 1
    [ExifImageWidth] => 2592
    [ExifImageLength] => 1944
    [ExposureMode] => 0
    [WhiteBalance] => 0
    [FocalLengthIn35mmFilm] => 22
    [SceneCaptureType] => 0
    [ImageUniqueID] => B05LLHA01PM
)

Here is Solutions:

We have many solutions to this problem, But we recommend you to use the first solution because it is tested & true solution that will 100% work for you.

Solution 1

You can ignore the error with

ini_set ('gd.jpeg_ignore_warning', 1);

(this is the default since PHP 7.1, but not in older versions)

See http://php.net/manual/en/image.configuration.php

Solution 2

I also get the same issue

we used below code to fix this issue and it works for me.

$image = @ImageCreateFromJpeg($image_name);
if (!$image)
{
$image= imagecreatefromstring(file_get_contents($image_name));
}

Note: Use and implement solution 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply