npm – Error: The specified procedure could not be found

Error:

module.js:347
        ' for module ' + JSON.stringify(this.id));
                       ^
Error: The specified procedure could not be found.
c:\Users\Artur\workspace\xxx\node_modules\gulp-sass\node_modules\node-sass\vendor\win32-x64\binding.node
    at Error (native)
    at Module.load (module.js:355:32)
    at Function.Module._load (module.js:310:12)
    at Module.require (module.js:365:17)
    at require (module.js:384:17)
    at Object.<anonymous> (c:\Users\Artur\workspace\xxx\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:211:15)
    at Module._compile (module.js:460:26)
    at Object.Module._extensions..js (module.js:478:10)
    at Module.load (module.js:355:32)
    at Function.Module._load (module.js:310:12)

System:

  • OS: Windows 8.1 (64-bit)
  • node: v0.12.0
  • npm: 2.5.1

Background:

Yesterday I was trying to start a new project. And tried to use yeoman generator generator-gulp-angular and got a bunch of visual basic errors. So I installed Microsoft Windows SDK and a bunch of other stuff from Microsoft. So now I have a lot of Microsoft entries in my installed applications listing and I’m lost when I look at these:

These might be relevant for the problem:

Microsoft Visual C++  x64 Libraries
Microsoft Visual C++  x86 Libraries
Microsoft Visual C++ 2005 Redistributable
Microsoft Visual C++ 2005 Redistributable
Microsoft Visual C++ 2005 Redistributable
Microsoft Visual C++ 2005 Redistributable (x64)
Microsoft Visual C++ 2005 Redistributable (x64)
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.4148
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.4148
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.4974
Microsoft Visual C++ 2010  x64 Redistributable - 10.0.40219
Microsoft Visual C++ 2010 Express - ENU
Microsoft Visual C++ 2012 x64 Additional Runtime - 11.0.61030
Microsoft Visual C++ 2012 x64 Minimum Runtime - 11.0.61030
Microsoft Visual C++ 2012 x86 Additional Runtime - 11.0.61030
Microsoft Visual C++ 2012 x86 Minimum Runtime - 11.0.61030
Microsoft Visual C++ 2013 32bit Compilers - ENU Resources
Microsoft Visual C++ 2013 Core Libraries
Microsoft Visual C++ 2013 x64 Additional Runtime - 12.0.21005
Microsoft Visual C++ 2013 x64 Debug Runtime - 12.0.21005
Microsoft Visual C++ 2013 x64 Minimum Runtime - 12.0.21005
Microsoft Visual C++ 2013 x86 Additional Runtime - 12.0.21005
Microsoft Visual C++ 2013 x86 Debug Runtime - 12.0.21005
Microsoft Visual C++ 2013 x86 Minimum Runtime - 12.0.21005
Microsoft Visual C++ 2013 x86-x64 Compilers

Microsoft .NET Framework 2.0 SDK (x64) - ENU
Microsoft .NET Framework 4 Multi-Targeting Pack
Microsoft .NET Framework 4.5 Multi-Targeting Pack
Microsoft .NET Framework 4.5 SDK
Microsoft .NET Framework 4.5.1 Multi-Targeting Pack
Microsoft .NET Framework 4.5.1 Multi-Targeting Pack (ENU)
Microsoft .NET Framework 4.5.1 SDK

I have no idea what I really need/don’t need or if anything is conflicting.

I didn’t get anything to work yesterday so I finished right there.

So today I found out that I had an old version of npm (1.4.28) and upgraded it to version 2.5.1. I just downloaded a new x64 installer from nodejs.org.

After that everything was broken. I can’t even run gulp serve anymore to launch my existing/working application. For hours I tried to download/repair/uninstall/install Windows SDK, nodejs etc. Tried a bunch of commands which I still don’t fully understand and I’m still lost.

Few things from the top of my head which I tried:

  • npm cache clean
  • deleted node_modules folder and ran npm install
  • tried some commands I found with node-gyp
  • tried to set the msvs_version attribute to something
  • restart

The error makes me think that something is wrong with some kind of a compiler.
But I have no idea what’s really going on. So I’m trying to understand what could be the cause of the problem? What should I try next to fix the error?

If any addition information is needed let me know.

Here is Solutions:

We have many solutions to this problem, But we recommend you to use the first solution because it is tested & true solution that will 100% work for you.

Solution 1

EDIT (APRIL 2ND, 2015):

Node-sass has since fixed the issue. You can safely use Node v0.12, just make sure to install the latest version of Node-sass and also update your local AND global version of Gulp (https://github.com/gulpjs/gulp/issues/873). I’ll leave the original response below for archiving purposes.


Uninstall Node v0.12 and install Node v0.10.28

http://nodejs.org/dist/v0.10.28/

You’ll want the .msi installer

That fixed the issue for me.

Apparently it’s an issue with node-sass that won’t be fixed until they update:
https://github.com/sass/node-sass/issues/653

Note: Use and implement solution 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply